Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-20-2013, 09:15 PM   #1
Senior Member
 
Flipside's Avatar
 
Join Date: Apr 2012
Location: Flushing, MI
Posts: 224
Grill works 1lb tank not 20lb

I have a cheap Walmart grill with 1lb tank. I put hose w. no adapters from 20 tank to the grill. It will not wrk right. Small flames and no heat. Why won't it work?
__________________

__________________
Joel

2012 Jay Flight Swift 267BHS
2015 Chevrolet Silverado 2500HD Z71 Crew Cab
Flipside is offline   Reply With Quote
Old 06-20-2013, 10:18 PM   #2
Senior Member
 
oobedoob's Avatar
 
Join Date: May 2013
Location: Kamloops
Posts: 267
Did you try closing the tank and opening it again slowly? the new safety valves can close if opened too quickly.
__________________

__________________
2013 Jayco Jay Flight Swift SLX 184BH
2012 Ram 1500
oobedoob is offline   Reply With Quote
Old 06-21-2013, 05:07 AM   #3
Senior Member
 
Threebutchers's Avatar
 
Join Date: Mar 2013
Location: Planet Earth
Posts: 6,818
Are you trying to run the grill off the TT external grill hook-up....or directly off a 20# tank with the hose you installed?

There needs to be a regulator between the tank and the grill or a safety valve in the 20# tank will trip. It's probable the gills regulator was part of the 1# tank adapter you removed to install the new hose. That being the case, you can not hook directly to a 20# tank but must go through the TT propane system which is regulated to 11" WC.....or install a standard propane gill hose with built-in regulator.
Threebutchers is offline   Reply With Quote
Old 06-21-2013, 05:54 AM   #4
Senior Member
 
RoyBraddy's Avatar
 
Join Date: Sep 2011
Location: King George
Posts: 2,397
X2 about the regulator -

I was going to do same thing and then got to thinking I really need to have a source of 1lb canisters with me at all time for PLAN Bs so having to use them for the grille makes me buy 6 at a time. My grille works just fine using the 1LB canisters... My alternate PLAN B heat source "MR BUDDY" heater uses the 1lb canisters also...

got to have PLAN Bs to be successful...

just my thoughts
Roy Ken
__________________
Roy and Carolyn
I claim Horse Creek Country in Southern Ill - Momabear is from North Texas
We live in King George VA
RETIRED DOD DOAF DON CONTRACTOR Electronics Tech 42YRS

"We're burning daylight" - John Wayne
2008 STARCRAFT 14RT OFF-ROAD POPUP with PD9260C and three 85AH 12VDC batteries
2010 F150 FX4 5.4 GAS with 3.73 gears - Super Cab - Towing Package - 2KW Honda EU2000i Gen
K9PHT (since 1957) 146.52Mhz
"We always have a PLAN B"
RoyBraddy is offline   Reply With Quote
Old 06-21-2013, 10:01 AM   #5
Senior Member
 
Join Date: Feb 2012
Location: Myrtle Beach, SC
Posts: 1,261
sounds like your running it double regulated (going off the TT tank/regulator and the one on the side of your grill)
exjay1 is offline   Reply With Quote
Old 06-21-2013, 01:44 PM   #6
Senior Member
 
Flipside's Avatar
 
Join Date: Apr 2012
Location: Flushing, MI
Posts: 224
I didn't change regulator. Just run hose from tank to grill.
__________________
Joel

2012 Jay Flight Swift 267BHS
2015 Chevrolet Silverado 2500HD Z71 Crew Cab
Flipside is offline   Reply With Quote
Old 06-21-2013, 06:49 PM   #7
Senior Member
 
Join Date: Apr 2013
Location: Cleveland
Posts: 1,435
Grill works 1lb tank not 20lb

Quote:
Originally Posted by Flipside View Post
I didn't change regulator. Just run hose from tank to grill.
Flipside, how are you connected? Do you have the hose directly into the 20lb tank and the hose directly into the stove? On the stove side, are you going through the roughly 10" pipe that you would normally screw on the 1lb canister to?

The 10" pipe contains a regulator and you must go through a regulator for the stove to work. The regulator can be on either side of the hose, however you must have a regulator for it to work (and only one).
__________________
2013 Jayco JayFlight 26RKS
2013 Ford F150 Ecoboost FX4

2003 Coleman Bayside / 2011 Jayco Jayfeather X20E -- RIP
2012 Tacoma Sport DCSB / 2013 Tundra SR5 - RIP
Heady is offline   Reply With Quote
Old 06-21-2013, 07:10 PM   #8
Senior Member
 
Join Date: Feb 2012
Location: Myrtle Beach, SC
Posts: 1,261
how about a pic of your grill/set-up?
exjay1 is offline   Reply With Quote
Old 06-29-2013, 01:30 PM   #9
Senior Member
 
Join Date: Oct 2010
Location: Merrimack NH
Posts: 804
1. Does the hose you connected to the 20 lb tank have the correct fitting to penetrate the fitting on the tank to release the pressure 2. Don't get me wrong but when you say " directly to the tank" I assume you don't have a regulator at that point but you do have a regulator at the grill.If you do have a regulator at both ends remove one, probably the one at the tank as I assume the one at the grill has the temp control. Larry
__________________

__________________
Larry & Rachel Demers 2013 F150 Eco Boost Super Cab 6.5 bed 6 sp. 3.31 4x4
29BHS ECO is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.