Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 08-09-2015, 10:23 AM   #1
Member
 
Join Date: Sep 2012
Location: Gainesville
Posts: 51
Another 12v question

Battery is new, charged, checked, with volt meter, and control panel, but nothing will run off just battery. Fuse in battery box appears to be good, any suggestions?
__________________

jstor1 is offline   Reply With Quote
Old 08-09-2015, 11:14 AM   #2
Senior Member
 
NVGun40's Avatar
 
Join Date: Feb 2015
Location: Eagle River, AK
Posts: 810
Is there an inline fuse just outside the battery?
How about the fuses in the panel inside?

If all that is good, take the fuse/circuit breaker panel out and check for fuse(s) in the side of the converter.
__________________

__________________
We are just a humble drinking couple with a hunting and camping problem.
2015 White Hawk 25BHS Glacier Package
2004 Dodge Ram 2500, 5.7 Hemi, 5Spd Manual
2008 Arctic Cat M1000 SnoPro
Previous: Northface tent/Komfort 5er/Jamboree MH
Lance Cabover/Prowler TT/WildernessTT/Tiltin Hiltin Cabover/Starcraft popup
NVGun40 is offline   Reply With Quote
Old 08-09-2015, 03:15 PM   #3
Senior Member
 
us71na's Avatar
 
Join Date: Jun 2013
Location: McKean, PA
Posts: 428
My trailer has two black wires that connect to the battery. One charges the battery, the other powers the 12 volt in the trailer.
__________________
2011 Skylark 21FKV
us71na is offline   Reply With Quote
Old 08-09-2015, 03:55 PM   #4
Senior Member
 
wags999's Avatar
 
Join Date: Jan 2015
Location: Surprise
Posts: 1,501
May want to check the ground.
__________________
2011 Toyota Tundra double cab
2015 27RLS
wags999 is offline   Reply With Quote
Old 08-09-2015, 06:22 PM   #5
Member
 
Join Date: Sep 2012
Location: Gainesville
Posts: 51
The fuse on the battery looked ok, just checked with meter, it had blown, headed to Walmart for a new one
jstor1 is offline   Reply With Quote
Old 08-09-2015, 07:29 PM   #6
Senior Member
 
Join Date: Apr 2015
Location: Elizabethtown, PA
Posts: 1,542
Quote:
Originally Posted by jstor1 View Post
The fuse on the battery looked ok, just checked with meter, it had blown, headed to Walmart for a new one
Hopefully many will learn from this Never just look at a fuse and assume it looks good. To me that is like trying to start your car and you hear a click and it doesn't start. Would you just open the hood and look at the battery and say it looks good?? Or would you test it to be sure? Same thing for fuses. Always best to test to be sure.
__________________
2004 Jay Feather 25E
2001 Ford Expedition 4X4 EB 5.4 3.55 rear
2004 Ford Expedition 4X4 EB 5.4 3.73 rear
bedrck46 is offline   Reply With Quote
Old 08-10-2015, 08:21 PM   #7
Member
 
Join Date: Sep 2012
Location: Gainesville
Posts: 51
Fuse

Camper running on battery, could hear circuit click as iplugged in fuse
jstor1 is offline   Reply With Quote
Old 08-10-2015, 08:23 PM   #8
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 5,045
Relay in the converter probably.
__________________
DISNEY LOVERS
PINNACLE 2015 38FLSA. aka: "Roam Sweet Home"
Grumpy is offline   Reply With Quote
Old 08-10-2015, 08:27 PM   #9
Member
 
Join Date: Sep 2012
Location: Gainesville
Posts: 51
Was the fuse, looked at it, didn't see the break inside the fuse, then I ckecked with meter, it was blown
__________________

jstor1 is offline   Reply With Quote
Reply

Tags
12 volt

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 12:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.