Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 03-23-2013, 11:27 PM   #1
Junior Member
 
Join Date: Nov 2012
Location: Washington state
Posts: 27
Lights Out

Latest issue with new Jayco Precept

Series of four ceiling lights from kitchen to bathroom sink suddenly quit working. Tested switch over bathroom sink (controls 2 light) and found no power. Finally after much searching, with no info in manual on location of, found 12V fuse panel and will now test fuses. Any suggestions would be greatly appreciated.

Jerrym

2010 Jayco Precept
3 L Mercedes Diesel
__________________

jerrym is offline   Reply With Quote
Old 03-24-2013, 08:34 AM   #2
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 5,037
I would also check the connections in the fuse panel. Wires have been known to come loose due to not being properly connected. Some are even attached to pig-tails using wire nuts.
__________________

__________________
DISNEY LOVERS
PINNACLE 2015 38FLSA. aka: "Roam Sweet Home"
Grumpy is offline   Reply With Quote
Old 03-24-2013, 08:37 AM   #3
Moderator Emeritus
 
Doug's Avatar
 
Join Date: Oct 2012
Location: Cincinnati, Ohio
Posts: 4,761
Likely a fuse to that circuit.
Check for any loose connections as Grumpy states.

Let us know what you find.
__________________

Southwest, Ohio
2016 Toyota Tundra SR5, 5.7 V8
2017 Jayco 24RBS
Doug is offline   Reply With Quote
Old 03-24-2013, 09:58 PM   #4
Junior Member
 
Join Date: Nov 2012
Location: Washington state
Posts: 27
Quote:
Originally Posted by dougtoms01 View Post
Likely a fuse to that circuit.
Check for any loose connections as Grumpy states.

Let us know what you find.
Thanks dougtoms,

Checked fuses - all OK. Checked switch - no power. Will check connections, am opting for calling Jayco rep Phoenix in am since rig is still under warrantee. There's another issue as well now - a drip behind the kitchen sink that happened after encountering high water pressure at one RV camp. Possible that may be the problem (water shorting out light circuit?? don't know but will keep all informed. Been a learning experience in RVing.

Jerrym
jerrym is offline   Reply With Quote
Old 03-24-2013, 10:05 PM   #5
Junior Member
 
Join Date: Nov 2012
Location: Washington state
Posts: 27
Quote:
Originally Posted by Grumpy View Post
I would also check the connections in the fuse panel. Wires have been known to come loose due to not being properly connected. Some are even attached to pig-tails using wire nuts.
Grumpy, thanks for suggestion. I'm now planning on getting with Jayco rep here in Phoenix to see if they can look at the problem under warrantee. There's also a drip problem to check out.

jerrym

2010 Jayco Precept 24'
3.0 Mercedes diesel

Currently on roadtrip through out SW. Second road trip since purchase 1 year ago which was Kingston, NY to Seattle Washington via East Coast South and west coast. Love the motorhome but shaking out all the bugs.
jerrym is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.