Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-22-2015, 11:50 AM   #1
Member
 
Join Date: Oct 2013
Location: Central Wisconsin
Posts: 96
RVComfort.HP Thermostat Problem

I have read about others with the problem with their thermostats in that they would set the temp for furnace, say 60 degrees and later find that it is heating way higher like up to the factory setting of 72 degrees. Well, mine is doing this too. Called Jayco and was told that some of these for some reason are momentarily losing ground and resetting to factory setting. Since we are doing 6 weeks of campground hosting, Jayco agreed to ship the necessary part (a relay) along with instructions so that I may install to correct myself.

Again, Jayco has been very helpful in solving issues that come up with our new rig. Thank you Jayco!
__________________

__________________
2015 Jayco Greyhawk 29KS
JulieMike is offline   Reply With Quote
Old 05-22-2015, 02:58 PM   #2
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 12,056
Good to hear they are working with you.
__________________

__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is offline   Reply With Quote
Old 05-23-2015, 07:15 AM   #3
Member
 
Join Date: Jul 2014
Location: Bonaire
Posts: 34
I had the same problem on my unit this past winter. I took mine in for repair and they added an isolation relay to the system. The tech told me they were putting a lot of those in on new Jayco campers. Hope this helps.
__________________

Rick and Janet Harris
2015 Greyhawk 31DS
tow 2014 Honda CRV

rickyd53 is offline   Reply With Quote
Old 05-26-2015, 08:02 PM   #4
Senior Member
 
anav8or's Avatar
 
Join Date: Nov 2014
Location: Grove City, OH
Posts: 235
Thanks for the info. I'll add this to the list of items to have the dealer look at when the season ends. I had it happen a couple of times as well.
__________________
Ty & Deb Montag
Columbus, OH
2015 Jayco Seneca 36FK
2014 Honda CR-V toad

anav8or is offline   Reply With Quote
Old 05-27-2015, 02:10 PM   #5
Junior Member
 
Join Date: Apr 2015
Location: Philadelphia
Posts: 17
I had this problem with my thermostat also. The service department where I purchased my 31DS motorhome was told that the thermostat was picking up interference from the LED lights in the motorhome specifically the lights on the canopy. They installed the relay and It appears to have fixed the problem.
nascar64 is offline   Reply With Quote
Old 06-11-2015, 07:21 AM   #6
Member
 
adaigle's Avatar
 
Join Date: Oct 2011
Location: Smithtown
Posts: 81
My thermostat seems to work just fine when using the heat pump. When using the propane furnace it will not shut off until it reaches 72 degrees ???
__________________
2015 Jayco Precept 35 UP
2015 Jayco Greyhawk 31 DS (SOLD)
2009 Jeep Wrangler X
2012 Jayco Skylark (SOLD)
adaigle is offline   Reply With Quote
Old 06-11-2015, 09:46 AM   #7
Junior Member
 
Join Date: Apr 2015
Location: Philadelphia
Posts: 17
RV Thermostat problem on Gas Heat Setting

This appears to be a common problem with the heat pump/gas heat thermostat. I have a Jayco 31DS and had the same problem twice. Finally, the Jayco factory figured out the problem. The thermostat was picking up interference from the LED lights in the motorhome and it effected the thermostat in the gas heat mode. They installed an isolater relay kit. This fixed the problem so far. Hope this helps. This was done under warranty and no charge to me.
nascar64 is offline   Reply With Quote
Old 06-17-2015, 11:54 AM   #8
Member
 
Join Date: Oct 2013
Location: Central Wisconsin
Posts: 96
adaigle , you need the isolation relay kit supplied by Jayco to remedy this issue. Having my dealer install it next week.
__________________
2015 Jayco Greyhawk 29KS
JulieMike is offline   Reply With Quote
Old 10-10-2017, 12:49 PM   #9
Junior Member
 
Join Date: Oct 2017
Location: Kent
Posts: 2
Does anyone happen to know the part # of this isolation relay?
Suzuki12 is offline   Reply With Quote
Old 10-10-2017, 12:52 PM   #10
Junior Member
 
Join Date: Oct 2017
Location: Kent
Posts: 2
Does anyone happen to know the part # of this isolation relay, I am having the same problem with the gas heat setting on my heat pump thermostat on my 2014 Jayco Seneca.

Thank you.
__________________

Suzuki12 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.