Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-28-2021, 04:58 PM   #1
Member
 
Join Date: Nov 2020
Location: Southwest
Posts: 33
rooftop heat pump not working?

Our new Pinnacle came with a rooftop heat pump and I am trying to verify that it works before I start the season. Here is what I have for symptoms:
Outside temperature 58 degrees F
set thermostat to "electric heat" and 60 degrees for the setpoint
Heatpump runs with normal sounds
Heatpump output air is same temp as ambient air. It is not warm at all
Left it run for 5 minutes and there was no change in output temp.

I did not violate the ambient must be greater than 40 degree or the no more than 3 degrees between ambient and the setpoint requirements.

I am suspicious that the heat pump does not work. What is your opinion?


Additionally on a new unit that is still under warranty, do I use it for a season and record all of my squawks and then take it in and have all of the items fixed at once?
CraigBU is offline   Reply With Quote
Old 03-15-2021, 10:03 AM   #2
Member
 
Wind Bandit's Avatar
 
Join Date: Mar 2021
Location: Hamlin
Posts: 41
Quote:
Originally Posted by CraigBU View Post
Our new Pinnacle came with a rooftop heat pump and I am trying to verify that it works before I start the season. Here is what I have for symptoms:
Outside temperature 58 degrees F
set thermostat to "electric heat" and 60 degrees for the setpoint
Heatpump runs with normal sounds
Heatpump output air is same temp as ambient air. It is not warm at all
Left it run for 5 minutes and there was no change in output temp.

I did not violate the ambient must be greater than 40 degree or the no more than 3 degrees between ambient and the setpoint requirements.

I am suspicious that the heat pump does not work. What is your opinion?


Additionally on a new unit that is still under warranty, do I use it for a season and record all of my squawks and then take it in and have all of the items fixed at once?

I tested my heat pump the other day on my 2020 377, and the BMPRO says something like " fault see owners manual" I checked the manual and couldn't find anything! so, I'm in a similar boat, the blower blows but no heat.
Wind Bandit is offline   Reply With Quote
Old 03-15-2021, 12:37 PM   #3
Senior Member
 
AKRUEBBE's Avatar
 
Join Date: Apr 2018
Location: Natalbany Creek Campground, Amite City, LA
Posts: 2,966
I would check the connection on the heating element:

https://www.pplmotorhomes.com/parts/...ach-8-ac_62763
__________________
AL & JANET KRUEBBE
2019 PINNACLE 37RLWS
2018 NORTH POINT 315RLTS (TRADED)
2017 RAM 3500 DRW DIESEL/AISIN 4.10 AIR BAGS
B&W COMPANION TURN OVER BALL HITCH
Formerly from Sequim, WA
AKRUEBBE is offline   Reply With Quote
Old 03-15-2021, 02:01 PM   #4
Junior Member
 
Join Date: Nov 2020
Location: Roswell
Posts: 6
The supply air temperature for any heat pump system is typically only a few degrees warmer than the room ambient/return air. Test your room air and discharge supply air with the same thermometer to determine if it is working.
RuneMan is offline   Reply With Quote
Old 04-24-2021, 04:43 PM   #5
Member
 
Wind Bandit's Avatar
 
Join Date: Mar 2021
Location: Hamlin
Posts: 41
Quote:
Originally Posted by Wind Bandit View Post
I tested my heat pump the other day on my 2020 377, and the BMPRO says something like " fault see owners manual" I checked the manual and couldn't find anything! so, I'm in a similar boat, the blower blows but no heat.
we updated the firmware in the BMPRO command center doodad and bingo bango ours works flawlessly now!
__________________
2020 North Point 377 RLBH
2021 RAM 4500 Laramie 8' dually bed
Wife, Kiddo, a Pitbull.
Wind Bandit is offline   Reply With Quote
Old 10-24-2021, 12:20 PM   #6
Senior Member
 
Join Date: Jan 2021
Location: Covington
Posts: 140
How do you update the firmware? Is it done with an internet connection on your phone? or the BMPRO in the unit?
GeorgiaTrains is offline   Reply With Quote
Old 10-24-2021, 01:02 PM   #7
Member
 
Join Date: Nov 2020
Location: Southwest
Posts: 33
What finally fixed the problem was when the dealer realized that the factory mistakenly put the heat pump unit in the back bedroom and the back bedroom AC was installed in the kitchen where the heat pump was supposed to be. Once the two units were put in their proper places everything worked. It still cost me $80 to fix the warranty problem.
CraigBU is offline   Reply With Quote
Old 10-24-2021, 02:28 PM   #8
Senior Member
 
jetlag's Avatar
 
Join Date: May 2021
Location: Vanceboro
Posts: 699
Quote:
Originally Posted by GeorgiaTrains View Post
How do you update the firmware? Is it done with an internet connection on your phone? or the BMPRO in the unit?
You have to do it on the tablet in the camper. First you have to leave Jaycommand and go to settings. Then look for the Google logo, and click on it. if you have a google account, log in and head over to the play store. Now look for BMPRO Jaycommand, I seem to remember that, but Jaycommand will work. When you select it as if to install, it will recognize you already have it and ask you to upgrade. It will upgrade the APP on the tablet first, and shortly after it will tell you need to update the firmware right there. Once done and back in Jaycommand you will need to input your JayCommand login and password again. You are done! If you do not have a Google account obviously set one up and login before going to the App Store.,
__________________
2021 Ram Laramie 3500 SRW Air ride 50Gal fuel tank.
2021 Jayco Pinnacle 36FBTS, Andersen Ultimate Hitch
jetlag is offline   Reply With Quote
Old 10-24-2021, 02:31 PM   #9
Senior Member
 
jetlag's Avatar
 
Join Date: May 2021
Location: Vanceboro
Posts: 699
Quote:
Originally Posted by CraigBU View Post
What finally fixed the problem was when the dealer realized that the factory mistakenly put the heat pump unit in the back bedroom and the back bedroom AC was installed in the kitchen where the heat pump was supposed to be. Once the two units were put in their proper places everything worked. It still cost me $80 to fix the warranty problem.

Curious, what do you mean by the units were put in their proper place? Do you mean physically? or just software fix in the BMPRO? And why $80 for warranty work? Thanks
__________________
2021 Ram Laramie 3500 SRW Air ride 50Gal fuel tank.
2021 Jayco Pinnacle 36FBTS, Andersen Ultimate Hitch
jetlag is offline   Reply With Quote
Old 10-24-2021, 07:03 PM   #10
Member
 
Join Date: Nov 2020
Location: Southwest
Posts: 33
I mean our units was supposed to be configured with a 13.5KBTU AC in the rear bedroom, and the living room upfront and a 15KBTU heatpump in the center (kitchen). Instead the heat pump unit was installed in the back bedroom and the rear bedroom AC unit was installed where the heat pump was supposed to be in the center over the kitchen. First trip out the sail switch in the forced air furnace failed and the heatpump was inop. After we got these problems resolved, the camper has been trouble free.
CraigBU is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:19 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.