Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 07-02-2015, 07:28 AM   #1
Junior Member
 
Join Date: Jul 2015
Location: mesa
Posts: 11
Question Electrical Issues- No running lights or tail lights.

So I just bought my first pop up- we got it home hooked it up to the SUV had no lights except passenger tail light. tried a couple new fixtures and a couple bulbs. still nothing. checked all wiring from hitch to back end. Then my husband replaced the outside light by the table mount. All of a sudden everything worked for a second then gone.... now i have no lights outside. Where should i check next. Did he blow a fuse? Its a 1996 pop up with no ac and its a manual crank up.. Help we are hitting the road for 2 weeks in 2 days!!!
__________________

Amanda is offline   Reply With Quote
Old 07-02-2015, 07:44 AM   #2
Senior Member
 
tnchuck100's Avatar
 
Join Date: Jun 2012
Location: Sparta, TN
Posts: 1,174
1. Corrosion in the TV connection.
2. Loose ground connection to the popup frame.
3. Corrosion in the bulb sockets.
4. Loose wires at any connection point.
__________________

__________________
Chuck - Sparta, TN
2012 Jay Flight 22FB, 2 x Honda EU2000i
2013 GMC Yukon XL Denali AWD

EDUCATION is what you get when you read the fine print.....
EXPERIENCE is what you get when you don't.
tnchuck100 is offline   Reply With Quote
Old 07-02-2015, 07:47 AM   #3
Senior Member
 
Join Date: Apr 2015
Location: Elizabethtown, PA
Posts: 1,542
Check your wiring and ground connections clean any corrosion on wires
__________________
2004 Jay Feather 25E
2001 Ford Expedition 4X4 EB 5.4 3.55 rear
2004 Ford Expedition 4X4 EB 5.4 3.73 rear
bedrck46 is online now   Reply With Quote
Old 07-02-2015, 07:47 AM   #4
Senior Member
 
TWP723's Avatar
 
Join Date: Mar 2015
Location: Abingdon
Posts: 3,601
Check all your plastic pigtail connectors. Make sure they're all pushed tightly together. Also, as tnchuck100 suggested, check the ground connections.
__________________
2013 Jayco Eagle 328 RLTS
2013 Ford F350 6.7L 4x4 CCLB
W/Air Lift air bags (front & rear)
Equal-I-Zer™ WDH
Me, Momma and Charles (RIP buddy)
And introducing Sofie!! ;)
TWP723 is offline   Reply With Quote
Old 07-02-2015, 07:54 AM   #5
Junior Member
 
Join Date: Jul 2015
Location: mesa
Posts: 11
I feel stupid asking but what is the TV connection?
Amanda is offline   Reply With Quote
Old 07-02-2015, 07:55 AM   #6
Junior Member
 
Join Date: Jul 2015
Location: mesa
Posts: 11
i don't know how many grounds are on there but i have checked 3 and they were clean and tight.
Amanda is offline   Reply With Quote
Old 07-02-2015, 07:55 AM   #7
Senior Member
 
eng45ine's Avatar
 
Join Date: Oct 2014
Location: Suburbs of Chicago, IL
Posts: 668
Tow Vehicle
__________________
Frank
2014 Ford F150 SCab 4x4 5.0L Tuxedo Black Metallic
2017 Jay Flight 21 QB Elite
2015 Jay Series 1007 UD (sold)

"Life is so very short, eat the dessert first".
eng45ine is offline   Reply With Quote
Old 07-02-2015, 07:56 AM   #8
Senior Member
 
tnchuck100's Avatar
 
Join Date: Jun 2012
Location: Sparta, TN
Posts: 1,174
Quote:
Originally Posted by Amanda View Post
I feel stupid asking but what is the TV connection?
The connector that you plug the popup to the tow vehicle (TV).
__________________
Chuck - Sparta, TN
2012 Jay Flight 22FB, 2 x Honda EU2000i
2013 GMC Yukon XL Denali AWD

EDUCATION is what you get when you read the fine print.....
EXPERIENCE is what you get when you don't.
tnchuck100 is offline   Reply With Quote
Old 07-02-2015, 07:57 AM   #9
Junior Member
 
Join Date: Jul 2015
Location: mesa
Posts: 11
Thank you!
Amanda is offline   Reply With Quote
Old 07-02-2015, 08:20 AM   #10
Senior Member
 
fmichaels's Avatar
 
Join Date: Apr 2014
Location: pottsgrove
Posts: 191
if you lost all lights after replacing the bulb, it most likely is a fuse. as to how the fuse might have blown might be corrosion or some form of short at the light socket.
__________________

__________________
2013 23B
2001 Tahoe
Sold 2005 Fleetwood Allegiance
Sold 1999 Durango
fmichaels is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.