Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 10-01-2016, 06:56 AM   #1
Senior Member
 
tkhollywood's Avatar
 
Join Date: Jun 2014
Location: sterling heights
Posts: 123
Help no Heat

Got set up yesterday and daughter went to turn on the heat and nothing. We have a 2014 Whitehawk. Never had a problem before with the furnace. Checked all fuses, purged the gas line before we left home as usual so we can run the fridge while on the road. The A/C works and the fan works but when we switch to heat we get nothing. We don't have an access panel outside to check anything, but when I remove the inside access panel all I see is a box with duct work coming from it. Anyone have any ideas why it won't work.
__________________

__________________
2014 white hawk 33bhbs
tkhollywood is offline   Reply With Quote
Old 10-01-2016, 07:03 AM   #2
BJR
Member
 
Join Date: Oct 2014
Location: Bethlehem
Posts: 92
Quote:
Originally Posted by tkhollywood View Post
Got set up yesterday and daughter went to turn on the heat and nothing. We have a 2014 Whitehawk. Never had a problem before with the furnace. Checked all fuses, purged the gas line before we left home as usual so we can run the fridge while on the road. The A/C works and the fan works but when we switch to heat we get nothing. We don't have an access panel outside to check anything, but when I remove the inside access panel all I see is a box with duct work coming from it. Anyone have any ideas why it won't work.
There's a similar thread going here:
http://www.jaycoowners.com/forums/f7...srl-40145.html

I haven't had another chance to look at mine but it seems like it's dead. I was going to look at the thermostat today to see if I'm getting power and maybe short it out to see if the heat comes on.
__________________

__________________
2016 Jay Flight SLX 287BHSW
2015 Silverado 1500
BJR is offline   Reply With Quote
Old 10-01-2016, 07:50 AM   #3
Senior Member
 
Seann45's Avatar
 
Join Date: Jun 2010
Location: Saskatoon Sask Canada
Posts: 9,066
Check on top of the furnace.. mine has a little rocker switch that somehow got switched off..
__________________
Seann
2004 Chev Silverado Duramax optioned past the max. 2009 Jayco Eagle 308 RLS 765 watts of solar, 6-6 volt batteries (696 amp hour), 2000 watt (4000 surge) whole house inverter.
215 days boondocking in 2016
211/2015, 196/14, 247/13, 193/12

Seann45 is offline   Reply With Quote
Old 10-01-2016, 11:58 AM   #4
Senior Member
 
tkhollywood's Avatar
 
Join Date: Jun 2014
Location: sterling heights
Posts: 123
Tried the rocker switch and still nothing. Looks like yet another trip to the dealer.for once I wish I could take this thing out without problems or having to fix things.
__________________
2014 white hawk 33bhbs
tkhollywood is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.