Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-13-2015, 02:21 PM   #1
Senior Member
 
us71na's Avatar
 
Join Date: Jun 2013
Location: McKean, PA
Posts: 428
Skylark Heat Pump problem

I have a 2011 Jayco Skylark with the standard Dometic heat pump they came with. Last fall we went camping late enough in the year that we needed to use the heat instead of the A/C. I sent the temp where we wanted it and put the thermostat in heat mode and the unit started and warmed the trailer up nicely. Once it reached the temp setting the unit shut off. A while later, when the temperature in the trailer had dropped, the heat pump clicked, the fan ran for 1/2 second and stopped, ran for 2 seconds and stopped, then 5-10 seconds and stopped, 20 seconds and stopped and finally started and ran until the temp set point was reached. When the trailer cooled a bit again it did the same start stop routine. It continued doing this hesitant start thing throughout the night and into the next day until we left. Some times it would start and stop 2-3 times and other times it would take 4-5 false starts before it would run.

It does not do the false start thing in cooling mode. If you bump the temperature setting up a couple of degrees, it will immediately start up and run until the temp is reached. Voltage in the trailer was 123 volts on my digital voltmeter.

Has any other Skylark owner experienced this problem? My local dealer has been unable to solve the problem.
__________________

__________________
2011 Skylark 21FKV
us71na is offline   Reply With Quote
Old 06-28-2015, 07:19 AM   #2
Senior Member
 
us71na's Avatar
 
Join Date: Jun 2013
Location: McKean, PA
Posts: 428
After multiple weeks (6) and trips to the local Jayco dealer, I contacted Dometic customer service. Neither the dealer nor Dometic could solve the problem with my heat pump unit so it was replaced by Dometic.

I had asked the dealer early on to contact Dometic and instead they relied upon their own "expertise" which was unable to locate the problem. They replaced the thermostat and a circuit board which did not solve the problem. After threatening to take my trailer elsewhere and my call to Dometic, it was finally determined that the heat pump should be replaced. The new unit starts and operates normally.

My thanks to Rhonda at Dometic for taking care of this problem for me.
__________________
2011 Skylark 21FKV
us71na is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.