Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 04-03-2015, 10:12 PM   #1
Member
 
Moosiedad's Avatar
 
Join Date: Jun 2014
Location: Beavercreek
Posts: 30
Control Panel Question

What's the single, red, LED indicator between the electric and gas switches for the water heater? It's marked DSI • FLT and naturally there's nothing in the manual that refers to it.
__________________

__________________
Moosiedad

2014 White Hawk 30DSQB Summit Edition
2007 Ford Expedition EL 4X4 5.4L gas with 3.73 rear
Moosiedad is offline   Reply With Quote
Old 04-03-2015, 10:45 PM   #2
Senior Member
 
Skaling's Avatar
 
Join Date: Jul 2014
Location: Langley (Vancouver)
Posts: 397
direct spark ignition fault. Meant it tried to fire 3 times without success then will go into lock mode.
__________________

__________________
TT: 2015 Jayco Jayflight 26BH Elite
TV: 2014 Ram 1500 Sport, 5.7 HEMI 3.21, Firestone 1000# air suspension. WD hitch w/800# bars
SOLD: 2012 Jayco J-series 1007
Skaling is offline   Reply With Quote
Old 04-03-2015, 10:48 PM   #3
Senior Member
 
hoppers4's Avatar
 
Join Date: Mar 2015
Location: Port Orchard
Posts: 1,169
Lock can be reset by turning off the propane switch for the water heater. Turn it on again and you get three more tries. My last two rigs required a couple of resets to fire the propane side of the water heater if it had been sitting for a while.
__________________
Don
hoppers4 is offline   Reply With Quote
Old 04-03-2015, 11:07 PM   #4
Member
 
Moosiedad's Avatar
 
Join Date: Jun 2014
Location: Beavercreek
Posts: 30
Nailed it! Thanks guys!!
__________________
Moosiedad

2014 White Hawk 30DSQB Summit Edition
2007 Ford Expedition EL 4X4 5.4L gas with 3.73 rear
Moosiedad is offline   Reply With Quote
Old 04-04-2015, 06:13 AM   #5
Senior Member
 
edatlanta's Avatar
 
Join Date: Dec 2009
Location: Maplesville, AL - Home Base
Posts: 2,524
My water heater propane side will fail to light at times during thunderstorms and heavy rain. It did it again last night when weather moved through. I just reset the switch and all is well now. I have found through the years that when this starts to happen I go out to the heater and blow off the gas orifice, venturi tube, and burner tube with compressed air as well as the spark electrode. This eliminates the problem for a few weeks/months and then I have to do it again. No big deal and easy fix.
__________________
Ed
KM4STL

2006 GMC 2500HD CCSB 4x4 Duramax/Allison, Titan 52 gallon fuel tank, Prodigy Controller, B&W Companion Hitch
2010 Jayco Designer 35RLTS, Cummins/Onan RV QG 5500 EVAP, Progressive Industries EMS-PT50C, TST Systems 507 TPMS, RV Flex Armor Roof
edatlanta is online now   Reply With Quote
Old 04-04-2015, 08:50 AM   #6
Senior Member
 
Join Date: Aug 2011
Location: Missouri City, The Republic of Texas
Posts: 3,010
Ed, could that be a sign that the burner needs adjusting? Too much soot? Needing a cleaning that often sounds a bit too oftenjus wonderin'.
__________________
Cheers,
T_

2013 F-350 CC SB 2WD 6.7PS
2013 Eagle Premier 351 RLTS
-SOLD- 2012 X23B
-SOLD- 2003 Ford Expedition 5.4, Bilstein shocks
RedHorse1 is offline   Reply With Quote
Old 04-09-2015, 12:19 PM   #7
Senior Member
 
us71na's Avatar
 
Join Date: Jun 2013
Location: McKean, PA
Posts: 428
Check for spiders in the burner tube.
__________________

__________________
2011 Skylark 21FKV
us71na is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.