Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 01-20-2015, 10:13 PM   #1
Junior Member
 
Join Date: Jan 2015
Location: Tampa
Posts: 11
Tank gauge problem

I have a 2006 26bhs and the tank gauges don't light up at all. None of them. The 3 rocker switches work and light up but thats it. Any ideas?
__________________

dave8221 is offline   Reply With Quote
Old 01-20-2015, 11:18 PM   #2
Senior Member
 
Join Date: Oct 2014
Location: Houston
Posts: 222
If none of the gauges work on any of the tanks, I'd guess there's a power problem somewhere...perhaps inside that device with the lights. Check the fuse first, but then trace power to the device and then see if its functioning with some tests simulating the sensors. I'm not familiar with that end of it, but assume they have a different impedance when they have liquid on the sensor. You may need a new control box.
__________________

Dirkdaddy is offline   Reply With Quote
Old 01-21-2015, 05:45 PM   #3
Junior Member
 
Join Date: Jan 2015
Location: Tampa
Posts: 11
Thanks I will see if I can find a fuse tucked in behind it because I'm not able to see one for it on the fuse panel. all the fuses in the panel check good as well. thanks for the reply
dave8221 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.