Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 04-21-2018, 08:21 PM   #1
Member
 
Join Date: Mar 2016
Location: Southeastern CT
Posts: 59
Dishwasher detergent for black tank

Like everyone else, the level sensors in my black tank show it full all of the time. I've flushed, used cleaners, tried the GEO solution
(H2O softener, Dawn detergent, & water). Nothing has worked.

Tonight in the grocery store, I noticed all the dishwasher detergents. No suds, breaks down the nasty's. Why wouldn't it work?

Anybody tried it?
__________________

__________________
harryjr is offline   Reply With Quote
Old 04-21-2018, 08:23 PM   #2
Senior Member
 
Join Date: Jun 2017
Location: Tower City
Posts: 187
Iíve heard of others using it.
__________________

Fr8Train is offline   Reply With Quote
Old 04-21-2018, 08:33 PM   #3
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 14,425
It's worth a try if you care or have no other way to determine your usage.

I never look at my black tank gauge. I know we can stay 6 days before it needs to dump because we are the only ones using it.

Spent lots of time trying to get it accurate, now I use that time for other more productive tasks.
__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
norty1 is offline   Reply With Quote
Old 04-21-2018, 08:36 PM   #4
Senior Member
 
Join Date: Aug 2011
Location: Missouri City, The Republic of Texas
Posts: 3,515
I’ve had good results using Dawn. I travel with about 1/4 to 1/3 in the tank and a healthy shot of Dawn, 1/4 cup or so. I think the detergent and the sloshing turns the tide. I also store the 5th with the Dawn and water in the tank. The dishwasher stuff will probably do the job too. Did you buy it pre-owned, something left for you by the PO?
__________________
Cheers,
T_

2013 F-350 CC SB 2WD 6.7PS
2013 Eagle Premier 351 RLTS
-SOLD- 2012 X23B
-SOLD- 2003 Ford Expedition 5.4, Bilstein shocks
RedHorse1 is offline   Reply With Quote
Old 04-21-2018, 08:55 PM   #5
Member
 
Join Date: Mar 2016
Location: Southeastern CT
Posts: 59
Quote:
Originally Posted by RedHorse1 View Post
Did you buy it pre-owned, something left for you by the PO?
2011 purchased 2 yrs ago. The black tank sensors have never worked properly. Fresh water, grey tanks (2) all work fine.
__________________
harryjr is offline   Reply With Quote
Old 04-21-2018, 08:58 PM   #6
Senior Member
 
Join Date: Jun 2017
Location: Tower City
Posts: 187
Have you tried a tank wand? Works best when you are somewhere with excellent water pressure
Fr8Train is offline   Reply With Quote
Old 04-21-2018, 09:19 PM   #7
Member
 
Join Date: Mar 2016
Location: Southeastern CT
Posts: 59
Quote:
Originally Posted by Fr8Train View Post
Have you tried a tank wand? Works best when you are somewhere with excellent water pressure
Used the black tank flush connection many times. I thought a few times wetting the sensors down, letting the crud soften, and then blasting them would work, but so far no luck.
__________________
harryjr is offline   Reply With Quote
Old 04-21-2018, 09:21 PM   #8
Senior Member
 
Join Date: Jun 2017
Location: Tower City
Posts: 187
Quote:
Originally Posted by harryjr View Post
Used the black tank flush connection many times. I thought a few times wetting the sensors down, letting the crud soften, and then blasting them would work, but so far no luck.


Our rig has a tank rinse, but I also use a wand every so often.
Fr8Train is offline   Reply With Quote
Old 04-21-2018, 09:32 PM   #9
Senior Member
 
Join Date: Aug 2011
Location: Missouri City, The Republic of Texas
Posts: 3,515
When the trailer is in storage I’d fill the black tank and drop in some chems and give them a chance to work. It’s also possible the wiring is faulty or damaged. Does it always show full or empty? I’ve found if I have fouled sensors it will read full if they are damp but may show empty after the rig has sat still for a day or two (not in use).
__________________
Cheers,
T_

2013 F-350 CC SB 2WD 6.7PS
2013 Eagle Premier 351 RLTS
-SOLD- 2012 X23B
-SOLD- 2003 Ford Expedition 5.4, Bilstein shocks
RedHorse1 is offline   Reply With Quote
Old 04-21-2018, 10:21 PM   #10
Senior Member
 
BigJohnD's Avatar
 
Join Date: Nov 2014
Location: Florien, LA
Posts: 1,848
Try RVDigestit. Follow directions on bottle. I haven’t needed it, but I’ve done it to others and it fixed all of them.

I’m like norty though. I never look at the gauge. I know how long we can go before dumping.

As for what I use in the tank, any home brew I can think of. I always use calgon softener, but then add multiple things that all work. Dawn, purple power, laundry detergent etc. They all work.
__________________

__________________
John and Rebecca Dickson
Emma-9 / Little John-6 / Iva-2
2013 Ford F-350 Lariat FX4, CC LB PSD, DRW
2015 Jayco Jay Flight 28BHBE (#8)
BigJohnD is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.