Jayco RV Owners Forum
 



Reply
 
Thread Tools Display Modes
 
Old 09-20-2018, 10:57 AM   #1
Senior Member
 
Join Date: Mar 2017
Location: Redding
Posts: 117
Leveling issue Jayco Melbourne on MB Sprinter Chassis.

We are in a site that has level issues. We canít put enough blocks under the front wheels to get us level. The refrigerator doesnít seem to be keeping cold. It is on electricity but is being unlevel going to mess with it? We are level side to side. Front is low. Thanks
__________________

pamanc is offline   Reply With Quote
Old 09-20-2018, 03:37 PM   #2
Senior Member
 
Join Date: Apr 2016
Location: Henry
Posts: 478
I cant answer your question but it seems that even at so called level lots the front is always at least 3" low. Koko on this forum also stated they have the same issue.
__________________

__________________
2016 Melbourne 24K
2013 Sprinter crew cargo used for work and camper
Pfflyer is offline   Reply With Quote
Old 09-20-2018, 03:39 PM   #3
Senior Member
 
Join Date: Mar 2017
Location: Redding
Posts: 117
We ended up moving to another spot and refrigerator is working again. Iím glad it didnít seem to affect it long term. Iíve read that you need to be somewhat level but this surprised me.
pamanc is offline   Reply With Quote
Old 09-20-2018, 05:57 PM   #4
Senior Member
 
Join Date: Apr 2016
Location: Henry
Posts: 478
Mine is seldom dead on level but never bad enough for the refrigerator not to work right. Glad you are back on track and hope you have a good trip.
__________________
2016 Melbourne 24K
2013 Sprinter crew cargo used for work and camper
Pfflyer is offline   Reply With Quote
Old 09-20-2018, 06:06 PM   #5
Senior Member
 
Join Date: Mar 2017
Location: Redding
Posts: 117
We were really slanted forward and not comfortable putting more blocks under a front tire. Need to assess the campsite better next time. Thanks again
pamanc is offline   Reply With Quote
Old 09-20-2018, 08:22 PM   #6
Senior Member
 
Join Date: Apr 2016
Location: Henry
Posts: 478
I have 20 logos blocks but 4-1/2 - 5” is my limit.
__________________
2016 Melbourne 24K
2013 Sprinter crew cargo used for work and camper
Pfflyer is offline   Reply With Quote
Old 10-05-2018, 09:34 AM   #7
Senior Member
 
Join Date: Mar 2017
Location: Redding
Posts: 117
Water pump silent Jayco Melbourne 24K.
Does anyone know which fuse to check for the water pump? We have water when hooked up to a spigot. There is 2/3 tank of water in fresh tank. Nothing comes out of the spigots when we try to use the pump. Hubs says the controls are all correct ... city fill vs normal. We are on normal
__________________

pamanc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:19 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.