Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-05-2017, 10:23 AM   #1
Junior Member
 
Join Date: Jul 2016
Location: McDonough
Posts: 9
LCI Leveling System

LCI Leveling System Error "communication error check wiring". Anyone know where the LCI controller is located on a 2016 Jayco Pinnacle 36KPTS? any ideas other than controller that may be the issue? I have good battery power and I used generator and shore power without success, same error message.
taurus88two is offline   Reply With Quote
Old 06-05-2017, 12:47 PM   #2
Senior Member
 
Skidawg's Avatar
 
Join Date: Mar 2017
Location: Plover, WI
Posts: 154
88Two, had this once on my Pinnacle. I simply un-plugged the lead power wire coming into the controller, waited two minutes, plugged it back in and allowed it to factory re-set. No issues after that. You can also just simply remove the in-line fuse and re-insert and get the same results if the wires are tucked away to tightly. Good Luck
Skidawg is offline   Reply With Quote
Old 06-05-2017, 01:29 PM   #3
Senior Member
 
dalebra's Avatar
 
Join Date: Jun 2013
Location: Waconia, MN
Posts: 447
Quote:
Originally Posted by taurus88two View Post
LCI Leveling System Error "communication error check wiring". Anyone know where the LCI controller is located on a 2016 Jayco Pinnacle 36KPTS? any ideas other than controller that may be the issue? I have good battery power and I used generator and shore power without success, same error message.
Not sure about a Pinnacle. But for my 2016 Eagle the controller is mounted in the basement, on the drivers side, just inside the door on the ceiling. Check all the connectors. I had one pin on one connector that was not seated properly. Fixed it myself and have not had issue since.
__________________
2015 Chevy Silverado 2500HD CC Duramax
2016 Eagle 323LKTS Java
Pull Rite SuperGlide #4100 Hitch w/Mor-Ryde Pin Box
dalebra is offline   Reply With Quote
Old 06-05-2017, 02:41 PM   #4
Junior Member
 
Join Date: Apr 2017
Location: Woodward
Posts: 23
On the Seismic 355W it is located on the passenger side in the front part of basement. Please let us know where you find it.
SlingShot is offline   Reply With Quote
Old 06-05-2017, 04:02 PM   #5
Junior Member
 
Join Date: Jul 2016
Location: McDonough
Posts: 9
I will check it out. My touch pad is on the drivers side basement door. The wiring harness disappears behind the converter. I will have to check inside the basement doors. Thanks for your help.
taurus88two is offline   Reply With Quote
Old 06-05-2017, 04:06 PM   #6
Junior Member
 
Join Date: Jul 2016
Location: McDonough
Posts: 9
I unplugged the harness going into the touch pad several times without success. The frustrating part of this entire issue is the 5th wheel is just 13 months old and it's 112 miles from my primary house on my other property. I'm just trying to gather all info i can so when I get back hopefully I can fix. Of course LCI has not been much help at all other than taking to a dealer which id 65 miles away in the mountains.
taurus88two is offline   Reply With Quote
Old 06-05-2017, 04:07 PM   #7
Junior Member
 
Join Date: Jul 2016
Location: McDonough
Posts: 9
Dalebra, your pin connector was bad on the controller side or touch pad side?
taurus88two is offline   Reply With Quote
Old 06-17-2017, 03:41 PM   #8
Junior Member
 
Join Date: Jul 2016
Location: McDonough
Posts: 9
Problem found! Lose pin in the connector at the touch pad. Thanks Dale. Word on caution. Don;t look for much help with Lippert on the phone. Been talking with them for 2 weeks now about the issue. Since my RV was 112 miles away at my secondary property Taylor assured me he would be available Saturday to help trouble shoot the problem. He must still be sleeping and it's 5:50pm. I emailed and called the emergency number without success. Very, very poor customer service so donlt look to get much help. You would be better off finding help hear and in the LCI manuals.. fyi
taurus88two is offline   Reply With Quote
Old 06-18-2017, 02:50 PM   #9
Senior Member
 
dalebra's Avatar
 
Join Date: Jun 2013
Location: Waconia, MN
Posts: 447
Quote:
Originally Posted by taurus88two View Post
Problem found! Lose pin in the connector at the touch pad. Thanks Dale. Word on caution. Don;t look for much help with Lippert on the phone. Been talking with them for 2 weeks now about the issue. Since my RV was 112 miles away at my secondary property Taylor assured me he would be available Saturday to help trouble shoot the problem. He must still be sleeping and it's 5:50pm. I emailed and called the emergency number without success. Very, very poor customer service so donlt look to get much help. You would be better off finding help hear and in the LCI manuals.. fyi
Mine was on the controller. Glad you found the probelm.
__________________
2015 Chevy Silverado 2500HD CC Duramax
2016 Eagle 323LKTS Java
Pull Rite SuperGlide #4100 Hitch w/Mor-Ryde Pin Box
dalebra is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.