Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-13-2018, 06:35 PM   #1
Junior Member
 
Join Date: Sep 2017
Location: Gloversville
Posts: 2
No power unless battery disconnect is ON

2018 Jayco 27.5 RLTS. We had no problems last fall but this spring we have no power unless the battery disconnect is ON. Hooked to power at home. Batteries were filled & charged prior to putting in the unit. Everything worked fine until ( I'm assuming) batteries went dead. They don't appear to be charging while on shore power. I discovered today that once I switched battery disconnect to ON everything came back on in the unit. Prior to that I had no lights, fridge didn't work, slides wouldn't work. I'm very confused. I've gone through the fuses. Red light on circuit bird is not on....i believe that indicates a blown fuse for the disconnect.

Jim
Jimmy Eschler is offline   Reply With Quote
Old 05-13-2018, 08:28 PM   #2
Senior Member
 
Join Date: Sep 2015
Location: North Greenbush, NY
Posts: 752
Is there any output from the converter? Turn on some 12v lights. Unplug the shore power than plug it back in. Do the lights get a bit brighter when plugged in? There are better ways to check, with a meter, but this is the easiest method. Since you have an '18, getting the dealer to diagnose and fix should be easy.
__________________
Be Safe, and Everyone Goes Home,
Rick

2014 RAM Laramie 2500 w/6.7L Cummins Diesel and Automated Safety Hitch
2016 377RLBH Jayco North Point
300W of Suntech Solar w/Rogue MPPT Controller & Xantrex 2000W PSW Inverter
Fire_Instructor is offline   Reply With Quote
Old 05-14-2018, 05:52 AM   #3
Senior Member
 
Mopar_Earl's Avatar
 
Join Date: Oct 2016
Location: Saint Thomas, PA
Posts: 2,234
That's how they wire it at the factory. The converter output goes through the disconnect. I rewired mine so the converter powers the trailer with the disconnect off.


Earl
__________________
2017 Eagle 293RKDS, factory ordered, lots of mods and upgrades. More than I can list.
2018 Ram 3500 crew cab long bed SRW diesel 6spd Aisin 4wd Tradesman.
B&W Ram puck 5th wheel
Line-X premium
Mopar wheel to wheel steps
Mopar_Earl is offline   Reply With Quote
Old 05-14-2018, 06:51 AM   #4
Senior Member
 
Join Date: Aug 2011
Location: Missouri City, The Republic of Texas
Posts: 5,063
I discovered the same thing. Disconnect has to be on even if the battery is not connected.
__________________
Cheers,
T_

2013 F-350 CC SB 2WD 6.7PS
2013 Eagle Premier 351 RLTS
-SOLD- 2012 X23B
-SOLD- 2003 Ford Expedition 5.4, Bilstein shocks
RedHorse1 is offline   Reply With Quote
Old 05-14-2018, 07:31 AM   #5
Junior Member
 
Join Date: Sep 2017
Location: Gloversville
Posts: 2
Thanks all. That is what the dealer just told me. It's just that it seemed backwards to me. Battery disconnect "Off" would mean batteries are online but apparently it is the opposite. Everything is working fine since I turned it to the On position.
Jimmy Eschler is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 09:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.