Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-08-2017, 09:00 AM   #1
Junior Member
 
Join Date: Oct 2012
Posts: 25
Fresh water pump problem

Hi everyone,

I have a Jayco Skylark. Just got back from a camping trip where I was hooked up to a park hydrant. When we were getting ready to break camp, I put about five gallons of water into my fresh water tank. I had disconnected the water from the hydrant. I went inside and turned on the pump and nothing would pump. I then put the hose to fill the system in a water jug, turn the valve to let it suck out of the jug and the pump worked just fine. When I closed the valve for the hose, no water would pump from the fresh water tank. Ideas?

Jon
Zilbub is offline   Reply With Quote
Old 06-08-2017, 09:32 AM   #2
Senior Member
 
Join Date: Apr 2016
Location: SW Washington
Posts: 1,024
5 gallons is a small amount of water. It could be that your not level enough for the water to reach the intake point. Put in more water.
__________________
2009 F350 CC LB 4WD
2017 Jayco 355MBQS
Rustysocket is offline   Reply With Quote
Old 06-08-2017, 09:46 AM   #3
Junior Member
 
Join Date: Oct 2012
Posts: 25
Thanks. I was still set up level. The tank only holds 20 gal so it should have worked with 5 gallons.
Zilbub is offline   Reply With Quote
Old 06-08-2017, 10:22 AM   #4
Senior Member
 
Join Date: Apr 2016
Location: SW Washington
Posts: 1,024
Quote:
Originally Posted by Zilbub View Post
Thanks. I was still set up level. The tank only holds 20 gal so it should have worked with 5 gallons.
Probably something else then.
__________________
2009 F350 CC LB 4WD
2017 Jayco 355MBQS
Rustysocket is offline   Reply With Quote
Old 06-08-2017, 10:50 AM   #5
Junior Member
 
Join Date: Oct 2012
Posts: 25
Fixed

Good grief. I had closed the valve from my fresh water tank last fall when I winterized it. Amazing what you find when you have a flashlight.
Zilbub is offline   Reply With Quote
Old 06-08-2017, 11:16 AM   #6
Senior Member
 
Jagiven's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 9,876
Easy fix, glad you got it resolved!
__________________

2012 Jayco X23B
2020 Ram Laramie 3500 SRW Air ride 50Gal fuel tank.
2007 Dodge Dakota Quad Cab (sold)
Equal-I-zer 4-Point Sway Control
Jagiven is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.