Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-08-2018, 11:05 AM   #1
Junior Member
 
Join Date: Feb 2018
Location: Sadler
Posts: 2
CP100 Stereo

Am new to this forum and have already found very useful information, great site.
I have a 2017 Jayco Seneca Class C which came with a JBL CP100 stereo head unit. This stereo is a huge disappointment. I am an Android user and cannot get the unit to use Android Auto, backup camera is really flaky and the side cameras are a joke. You have to reach down to the bottom of the dash and flip a switch to see the side camera view. Thats really impractical while driving. To make this short, the CP100 is junk. I have done some research and found out that JBL actually never put this unit on the open market.
Anybody having the same problems? Has anybody replaced this head unit and what did you replace it with. Any recommendations? I tow a Jeep Wrangler 4D and like to leave the backup camera on when driving; helps when passing other vehicles and I like to see the tow.
tbwtexas is offline   Reply With Quote
Old 02-08-2018, 07:06 PM   #2
Senior Member
 
Robbbyr's Avatar
 
Join Date: Dec 2014
Location: Akron
Posts: 3,207
Welcome to the forum and to the Jayco family!

I am not familiar with your head unit so I can't offer any specific information. But having to operate a switch to operate the sideview cameras is unusual to me. Generally they come on with the particular turn signal. Now that was distracting to some of us so we installed a cutoff switch so we can decide whether they respond to the turn signals or not. I am wondering if someone installed a switch on your unit. I know other new Senecas work like mine (did), so I am wondering why yours is different?

Did you buy new? If so you should be able to get these issues resolved under warranty. You would certainly not be the first owner to have issues with the stock head unit.

My 2014 came with a Clarion unit which failed while I was in warranty, but I did not want the same unit reinstalled. So I did it myself with Clarion giving me a substantial "goodwill" discount on a much better unit. Very happy now.
__________________
Rob R.
Akron, OH
2014 Seneca 37TS
Toads: 2019 Ford Edge ST or 2013 Ford Focus ST
Robbbyr is offline   Reply With Quote
Old 02-08-2018, 07:25 PM   #3
SJD
Member
 
Join Date: Nov 2016
Location: Columbia
Posts: 54
You need to contact Jayco to have them send you a replacement. I have a 2017 Seneca 37FS that came with a CP100 and multiple issues. Jayco sent me a new CP100 and I had it put in at a service center with no improvement. They then sent me a Pioneer 4200NEX, works great. They paid for all installs and reinstalls. Jayco knows the issue with these units, just contact them and not the dealer.
SJD is offline   Reply With Quote
Old 02-08-2018, 08:01 PM   #4
Senior Member
 
Join Date: Oct 2016
Location: Albuquerque
Posts: 357
I have a Jensen JRV9000R. I am pleased with it. It has been replaced once by Jayco for faulty hardware. The new one I have has been great. All three cameras work, triggered off the turn signals and reverse. Of course you can view them manually if desired. The nav is OK, but the garmin is better.
__________________
2016 Seneca 37FS
DW+7 kids+2 dogs=bunkhouse required
RyRoRyan is offline   Reply With Quote
Old 02-10-2018, 04:21 PM   #5
Junior Member
 
Join Date: Feb 2018
Location: Sadler
Posts: 2
Thanks for the info. I contacted Jayco and got very little help. Of course they said I need to take the unit in to a dealer and have it checked out first. My choice is to go to Camping World and I don't want to have to leave it 1-2 months for them to look at the stereo. Jayco also said they were not familiar with any issues with this unit which is BS.
Anyway, I was curious about your Pioneer 4200. Do you use it with Android Auto? Who did the install for you? I am seriously thinking about buying this stereo head but I don't want to have the same connection problems using Android Auto. Have watched several videos on the Pioneer and am a little bit nervous about the unit working with my Samsung phone and also the backup camera. Any help would be appreciated. Thx.
tbwtexas is offline   Reply With Quote
Old 02-10-2018, 07:20 PM   #6
SJD
Member
 
Join Date: Nov 2016
Location: Columbia
Posts: 54
I had it installed at a local RV shop who was approved by Jayco. My dealer is six hours away so no way was that going to happen. My pioneer works great with the cameras. They come at every turn with use of turn signals. I too like to watch my toad and there is no issue. When I had it installed the tech only had a Samsung phone so that is how it was set up, I switched to an iPhone for my use. The Samsung worked well for him the shop as that is how he gave me a tutorial. Yes Jayco knows of the problem. The gentleman I dealt with @ Jayco motorized services is Paul Martin. If you need additional info pm me and I will set up a time to talk by phone.
SJD is offline   Reply With Quote
Reply

Tags
cp 100, jbl stereo

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.