Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 10-26-2015, 07:58 PM   #1
Junior Member
 
Join Date: Aug 2015
Location: Peyton
Posts: 10
Priming the water pump to winterize

Hi,
We have a new Jayco Redhawk and we are trying to winterize it for the first time. We can not get the water pump to prime. Any suggestions??

Thanks
__________________

kimngreg is offline   Reply With Quote
Old 10-26-2015, 08:04 PM   #2
Site Team
 
Crabman's Avatar
 
Join Date: Nov 2010
Location: Virginia`s Eastern Shore
Posts: 14,656
Put the clear hose in the jug of antifreeze and make sure the valve is on and the valve coming from the fresh water tank is off. Pics of these hoses/valves are in this thread:

https://www.jaycoowners.com/forums/f1...12-a-9335.html
__________________

__________________
2017 Coachmen Catalina 283RKS
2004 Chevy 2500 HD CC 6.0l
2010 Jayflight 28BHS (sold)
Crabman is online now   Reply With Quote
Old 10-26-2015, 09:47 PM   #3
Member
 
Join Date: Jul 2014
Location: Fountain
Posts: 75
Remove the screen assembly from the hose hook up on the camper. Replace it backwards to where the cone is pointed in instead of out. This will open the valve that is keeping your pump from priming and pumping. When completed just reverse the screen to the original position. Good luck!
Cunning193 is offline   Reply With Quote
Old 12-04-2015, 08:13 PM   #4
Senior Member
 
Bikester's Avatar
 
Join Date: Aug 2013
Location: Hackettstown, NJ
Posts: 511
Quote:
Originally Posted by Cunning193 View Post
Remove the screen assembly from the hose hook up on the camper. Replace it backwards to where the cone is pointed in instead of out. This will open the valve that is keeping your pump from priming and pumping. When completed just reverse the screen to the original position. Good luck!

This feedback saved me a ton of time today when I was winterizing. I couldn't get the antifreeze primed, and this was the exact issue. The helpful hint is no where in the Jayco manual, and I haven't seen it on this forum before. Thank you!!!

Now it's all tucked in for winter
Click image for larger version

Name:	ImageUploadedByTapatalk1449281618.768227.jpg
Views:	12
Size:	414.3 KB
ID:	21075
__________________
2015 Jayco Greyhawk 31FS-"Scamper"
2015 Subaru Forester 2.5i Prem. 6 Spd
Blue Ox Aventa LX Tow Bar
2014 Jayco Jay Feather X23B-"Glampy"(Sold)
DW, DS, DDx2, and Bandit & Fletcher
Bikester is offline   Reply With Quote
Old 12-04-2015, 09:00 PM   #5
Member
 
Join Date: Jul 2014
Location: Fountain
Posts: 75
Glad I could help! Your most welcome! Happy Holidays!!
Cunning193 is offline   Reply With Quote
Old 12-05-2015, 10:06 AM   #6
Junior Member
 
Dlivrr's Avatar
 
Join Date: Feb 2015
Location: Columbus, IN
Posts: 28
Quote:
Originally Posted by bikester View Post
this feedback saved me a ton of time today when i was winterizing. I couldn't get the antifreeze primed, and this was the exact issue. The helpful hint is no where in the jayco manual, and i haven't seen it on this forum before. Thank you!!!
ditto!!!!!!
__________________
Brian and Joni
2015 Greyhawk 31FS
Dlivrr is offline   Reply With Quote
Old 12-05-2015, 12:33 PM   #7
Senior Member
 
Mr.Oz's Avatar
 
Join Date: Jul 2014
Location: Hebron
Posts: 214
Quote:
Originally Posted by Cunning193 View Post
Remove the screen assembly from the hose hook up on the camper. Replace it backwards to where the cone is pointed in instead of out. This will open the valve that is keeping your pump from priming and pumping. When completed just reverse the screen to the original position. Good luck!
+1.....excellent advise. This was the problem the first time I went to winterize a RV.
__________________
Dan
2014 Seneca 37 FS
2014 Jeep Wrangler Sahara Unlimited
Mr.Oz is offline   Reply With Quote
Old 02-13-2016, 03:15 PM   #8
Member
 
CanucksVenturingSouth's Avatar
 
Join Date: Jan 2016
Location: Ancaster
Posts: 41
If the water pump wont prime (with the clear hose method), open the low point drains until antifreeze comes out. Then close and continue with the winterizing.

2013 Greyhawk 31FS
CanucksVenturingSouth is offline   Reply With Quote
Old 02-13-2016, 08:37 PM   #9
Senior Member
 
Join Date: Jun 2015
Location: Elk city
Posts: 177
I have to make sure the antifreeze jug is above the pump when I winterize.
__________________

Mwade is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 10:27 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.