Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 02-21-2016, 10:32 AM   #751
Member
 
Join Date: Sep 2015
Location: Sault Ste Marie
Posts: 80
Clean off the snow...sure rub it in
__________________

Soltice is offline   Reply With Quote
Old 02-21-2016, 11:34 AM   #752
Senior Member
 
tuckerdog1's Avatar
 
Join Date: Apr 2015
Location: TX
Posts: 232
Quote:
Originally Posted by Gunnar View Post
I ordered these on Tuesday and they came in on Wednesday.

Attachment 22111

I am not really a fan of the black plastic running boards so........I was checking out side steps on the old internet.

I found these and thought not too bad looking. They were listed at $345 plus taxes and whatever the bracket kit cost. Now remember that I am in BC Canada.

I thought I would see if my local parts store carried these. He says yep we can get them. I ask how much. I figured if they were in the $500 neighborhood I would take the plunge.

Ok here is the punch line. Now remember I get a pretty good price because I do a lot of business there. So here is the surprise..............$333 out the door, taxes and bracket kit.
Gunnar,
I just went through that same process of choosing a set of side steps. Thought I'd looked at everything. However, I never saw a set with adjustable positions for the steps. Hope they work out well for you. Please post pics once installed.

Tuckerdog1
__________________

__________________
2012 X213
2016 RAM 2500 Cummins SLT Lone Star LB SRW

Do not handicap your children by making their lives easy.

You live and learn, or you don't live long.
tuckerdog1 is offline   Reply With Quote
Old 02-22-2016, 02:52 PM   #753
Senior Member
 
Join Date: Sep 2014
Location: Cincinnati
Posts: 220
Well, technically it was Saturday...and technically my brother-in-law did most the work. I just tried to help.

- Rebuilt a leaking power steering pump
- replaced a leaking power steering high-pressure line
__________________
Charles in Cincinnati, OH.
2006 Honda Ridgeline
2011 Jayco x23B
Blue Ox SwayPro WDH
charles_cincy is offline   Reply With Quote
Old 02-22-2016, 03:25 PM   #754
Senior Member
 
Join Date: Sep 2013
Location: South Texas
Posts: 3,699
Gave her a bath ... finally! You could just about stand the brush up in the bucket it was so dirty. My dad shamed me into it...
__________________


2014 Jay Flight 28 BHBE
2015 RAM 2500 6.4L HEMI, Tradesman 4x4, 3.73
Blue Ox SwayPro (BXW 1503)

Upgraded from an REI internal frame backpack and a Eureka 1/2 dome tent!
Camper_bob is offline   Reply With Quote
Old 02-22-2016, 06:31 PM   #755
Senior Member
 
Tunce the traveler's Avatar
 
Join Date: Aug 2013
Location: Bellingham,Wa.
Posts: 4,006
Changed the oil and topped off the Add-Blu tank so we're almost ready for the 1st trip of the year. Early spring in Vancouver and then the Oregon coast and far into California.
__________________
2010 Jayco Hybrid EXP21M
2013 Toureg TDI
Tunce the traveler is offline   Reply With Quote
Old 02-23-2016, 05:43 AM   #756
Senior Member
 
edatlanta's Avatar
 
Join Date: Dec 2009
Location: Maplesville, AL - Home Base
Posts: 2,309
Replaced the fuel filter. When removing the water sensor to move to the new filter I noticed one of he electrical wires was broken off. So I asked a friend that was coming this way to bring me a new one. The original one lasted through 15 previous filter changes so I guess it was about time. I'm not sure of he real value in this sensor since I have never seen any water in my filter during a change and the sensor has never gone off. Hopefully it will show up a bad load of diesel if I ever get one which I have not had a problem with in 18 years of driving diesel trucks every day.
__________________
Ed
KM4STL

2006 GMC 2500HD CCSB 4x4 Duramax/Allison, Titan 52 gallon fuel tank, Prodigy Controller, B&W Companion Hitch
2010 Jayco Designer 35RLTS, Cummins/Onan RV QG 5500 EVAP, Progressive Industries EMS-PT50C, TST Systems 507 TPMS, RV Flex Armor Roof
edatlanta is offline   Reply With Quote
Old 02-23-2016, 06:38 AM   #757
Site Team
 
Crabman's Avatar
 
Join Date: Nov 2010
Location: Virginia`s Eastern Shore
Posts: 13,953
The instrument cluster died. Removed it, sent it off to be rebuilt, got it back and reinstalled it. Obviously this was more then a one day event.
Crabman is offline   Reply With Quote
Old 02-23-2016, 01:18 PM   #758
Senior Member
 
Join Date: Sep 2013
Location: South Texas
Posts: 3,699
Quote:
Originally Posted by Crabman View Post
The instrument cluster died. Removed it, sent it off to be rebuilt, got it back and reinstalled it. Obviously this was more then a one day event.
Same thing happened to my dad's a few years ago. Is that a common problem?
__________________


2014 Jay Flight 28 BHBE
2015 RAM 2500 6.4L HEMI, Tradesman 4x4, 3.73
Blue Ox SwayPro (BXW 1503)

Upgraded from an REI internal frame backpack and a Eureka 1/2 dome tent!
Camper_bob is offline   Reply With Quote
Old 02-23-2016, 01:51 PM   #759
Senior Member
 
ALJO's Avatar
 
Join Date: Oct 2014
Location: Sparwood, BC
Posts: 937
Send a message via Skype™ to ALJO
Got the TV oil (full synthetic) and filter changed for hauling the TT home [900 mile round trip) Had to get a drop shank extra long (11 1/4). The top of the hitch coupler on the 2005 Jay Feather LTG 29Y is only 18" high. On my sold TT it was 25". So all set up and ready to go "no wasting time" at the dealer. So it would be an early rise and late coming home.
__________________
2014 Ram 1500 CrewCab 4x4 5.7 Hemi 3.92 Rear and Air Lift 1000
2005 Jayco Jay Feather LGT - 29Y GVWR-6500 lbs.
Pro Series 1200 lbs. WDH with Double Sway Bar.
Champion 3100/2800 watt Inverter/Generator-Onboard Solar Power

ALJO 'Forever Young @ Heart' provide on their travels Music Entertainment to Senior Care Homes
ALJO is offline   Reply With Quote
Old 02-23-2016, 08:43 PM   #760
Site Team
 
Crabman's Avatar
 
Join Date: Nov 2010
Location: Virginia`s Eastern Shore
Posts: 13,953
Quote:
Originally Posted by Camper_bob View Post
Same thing happened to my dad's a few years ago. Is that a common problem?
It is in the 2003-2005 range. Either the stepper motors on individual gauges would go bad or the entire cluster would lose power. I have had the cluster rebuilt in both my 04 trucks now, about a 100.00 proposition to do so. I remember in my 1500 the speedo sometimes when acting up would show 0 and sometimes 120. On a scout trip once a scout looked at the speedo from the back seat and asked are we really going 120 MPH? I said yep.
__________________

Crabman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 10:06 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.